Drivers Nvidia 190, Archlinux y VDPAU

Hace ya un tiempo hice un post sobre el tema, donde comentaba lo bueno que esta esto, mientras que a la ves comentaba como instalarlo y configurarlo en Ubuntu. Debo decir que las cosas han cambiado para Karmic Koala. Han cambiado por el hecho de que varios en Jaunty (incluido yo) usábamos totem-xine, bien, en Karmic se han tomado el atrevimiento de hacerlo un paquete de transición a este, es decir, no tiene nada. Por mas que lo instalemos, configuremos y demás Totem funcionará solo con Gstreamer.

Pero no todo esta perdido, hay dos, no, tres opciones. La primera sería instalar algún reproductor que use el motor xine, la segunda instalar Mplayer con algun frontend, sea por ejemplo SMplayer (es la que elegí yo) y la tercera (solo doy la idea) compilar la versión 2.26 de totem-xine, esto es para los mas fieles al reproductor, pero como ven, se soluciona rapido la cosa, más aun cuando en el repositorio con los drivers y la librería vdpau están todas las opciones de as que les hablé. Ya edité el post, así que cualquier duda acerca de ello lo ven ahí.

Bien, ahora viene el rollo, Archlinux. Para los que están con los drivers 185 de Nvidia deben instalar la libreria libvdau:

sudo pacman -S libvdpau

Aunque recomendaría actualizar los drivers. ¿Y los que tenemos los drivers 190? Eso me pregunte yo, ya que en los paquetes disponibles de Arch, la única versión disponible de esta librería es la 185. Y ahí investigando un poco me di con que el paquete que provee los drivers (190) también provee la librería mencionada, esto quiere decir que si tenemos instalada la versión 190 de los drivers de nvidia también tenemos instalado VDPAU, por lo que no queda nada por explicar acá.

Actualización: Se debe actualizar el sistema (mas precisamente los drivers) e instalar antes de hacer nada obligatoriamente el paquete libvdpau ya que cambiaron varias cosas, antes no se tenia que hacer, ahora si:

sudo pacman -Syu && sudo pacman -S libvdpau

Ahora vamos a los reproductores. Como no todos tienen tarjetas Nvidia, y dentro de los que las tienen no todas son compatibles, todos los reproductores que instalemos con pacman (cuando digo con pacman me refiero a instalarlos desde los repositorios oficiales), sea por ejemplo Mplayer, no vienen con VDPAU activado, lo cual es lógico. La única solución es compilar por nosotros mismos, nada dificíl usando ABS, no voy a explicar como configurarlo porque en la wiki de Arch esta muy bien hecho, así que, como diría un profesor mio, queda como ejercicio para el lector.

Una ves configurado ABS, abrimos la terminal y pegamos lo siguiente (en caso de haber dejado el arbol por defecto de ABS):
cd /var/abs/extra/mplayer && makepkg -i
con eso debería empezar la compilación y posterior instalación.

En caso de que te tire algun error con los permisos copia los archivos que encuentran en la carpeta, pegalos en otra la cual no debe tener espacios en el nombre de la misma -sigo sin entender porque-, y ahi ejecuta:

makepkg -i

Después solo resta instalar alguna GUI, sea por ejemplo SMplayer o Gnome-Mplayer, para ambos casos se lo puede hacer tranquilamente con pacman (repito, desde los repos oficiales)

Una ves instalado todo, configuramos el reproductor para que use el driver de salida VDPAU, esto se hace en Opciones->Preferencias->Video->Driver de salida: VDPAU o Edición->Preferencias->Reproductor-Salida Video: VDPAU en SMplayer y Gnome Mplayer correspondientemente.

Anuncios

Un pensamiento en “Drivers Nvidia 190, Archlinux y VDPAU

  1. Pingback: VDPAU en Archlinux « Sin titulo

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s